Help talk:Model Viewer

From Team Fortress Wiki
Jump to: navigation, search

I created this page in hopes of it being the pretty much definitive guide to using the program with TF2. At the moment it has a lot of room for expansion, but soon I hope to extend it to include more detailed guides with screenshots and small hints that everyone knows about but aren't written down anywhere. For now it should remain in the Help namespace (unless we get the 'Guide' space soon) as it shouldn't be in the article space (not strictly encyclopedic). If anyone can add anything extra to the page then please do, the page is far from complete and should be, in my mind, as detailed as it possibly can get. seb26 [talk] 07:05, 27 November 2010 (UTC)

Help: Model Viewer still uses default settings

I've put in the DeviceID of my graphics card and i have the dxsupport.cfg in the bin/orangebox/bin directory but Model Viewer still has the default settings, since my graphics card was unlisted, i used ATI Unknown, i've also made sure there were no typos or anything that could have messed it up, but everything is correct

"17"
{
"name" "ATI Radeon HD 5670"
"VendorID"	"0x1002"
"MinDeviceID"	"68D8"
"MaxDeviceID"	"68D8"
"DxLevel"	"99"
"ConVar.mat_antialias"	"8"
"ConVar.mat_forceaniso "8"
"ConVar.mat_picmip"	"-10"
"ConVar.mat_motion_blur_enabled"	"1"
}

Is there a way you guys can help me with this?

Fire overlay removable link is broken

The download link to the texture that removes fire overlay is broken it seems. Could we get a replacement up, please? Keychain 04:30, 19 September 2011 (PDT)

It's working fine for me, however there's no harm having a mirror. Here it is on my Dropbox. -RJ 04:37, 19 September 2011 (PDT)
Thank you! Keychain 20:34, 19 September 2011 (PDT)

dxsupport.cfg

Should this part of the page be updated? At the very least in my version of dxsupport, it includes references to cards that came out after 2007. Omolong (talk) 09:59, 21 June 2013 (PDT)

No need, should just work. – Smashman (talk) 10:28, 21 June 2013 (PDT)
When I tested it earlier, the edited dxsupport.cfg I already had worked fine, the AA showed up and so on. But when I used the one on here just to test it, there was no longer any AA or anything. Maybe just uploading a newer version of the file and getting rid of the out of date references would do it? Omolong (talk) 10:32, 21 June 2013 (PDT)

Weapon textures still bad even after taking both steps?

Alright so I made a profile for model viewer in my Nvidia control panel and it didn't fix it, so I tried the dxsupport.cfg thing and it still looks bad. Any Idea what I did wrong?
It's only the weapon models that are bad for some reason... Bojjob 14:44, 22 September 2015 (PDT)

Can you post a photo? It's quite hard to say what's wrong with only descriptions. Darkid (Talk | Contribs) 15:58, 22 September 2015 (PDT)
Yeah, here it is:
I pasted the thing from the dxsupport part into my graphics card on the dxsupport.cfg as well
User bojjob bad textures.png
Bojjob 00:16, 23 September 2015 (PDT)
Always use c_models weapons (if they're available), because they have better quality. Also use "hwm" models for the player classes, as they have better face textures and better facial flexes. The issue may be with the c_models, I would say. User Gabrielwoj Signature 1.pngUser Gabrielwoj Signature 2.png - User Gabrielwoj Signature 3.png 05:29, 23 September 2015 (PDT)
Blimey, that's all it was. Thank you so much! Bojjob 11:52, 23 September 2015 (PDT)
I'm happy that a new image contributor appeared. I was the only one for quite some time here, and it was tough to make the few cosmetics that the Gun Mettle Update had. If you want, add me on Steam that I'll give you some good tips with the images (about lighting, cropping, facial flexing, etc). Also, you may want to tweak your dxsupport.cfg a little bit, the texture quality isn't at the highest yet (as checking on your Heavy Mercenary badge, showing the pixelated emblem). User Gabrielwoj Signature 1.pngUser Gabrielwoj Signature 2.png - User Gabrielwoj Signature 3.png 16:55, 23 September 2015 (PDT)
I tried adding you but you declined Bojjob 02:07, 2 October 2015 (PDT)

Glitched Scout Gloves

Does anyone have any idea why all of scouts gloves are doing this for me:

User Bojjob Userlink.png 12:39, 5 December 2015 (PST)